2.1.2 เซต Loadbalance+Hotspot (1 PPPoE และ 1 Static)

วิธีการติดตั้ง และปรับแต่งอุปกรณ์ Mikrotik
ให้รองรับการทำงานที่หลากหลายความต้องการ
การติดตั้ง HotSpot Server, การติดตั้ว Load Balanced ฯลฯ

2.1.2 เซต Loadbalance+Hotspot (1 PPPoE และ 1 Static)

โพสต์โดย jadeson เมื่อ พุธ 08 มิ.ย. 2016 3:30 pm

รูปภาพ 2.1.2 เซต Loadbalance+Hotspot (1 PPPoE และ 1 Static)
บทความสำหรับ: ผู้ที่มีความรู้เกี่ยวกับระบบเครือข่ายในระดับเบื้องต้นถึงปานกลาง (v1.1)
โดย วิทวัส โฉมประเสริฐ, ศุภสิทธิ์ ศิริพานิชกร, เจตน์สันติ์ ยาวิลาศ

คำถาม

ต้องการทำ LoadBalance รวมเน็ตจำนวน 2 เส้น โดยมีขา WAN 2 เส้น
- WAN1 เป็น PPPoE โมเด็มเป็นแบบบริดจ์มา แล้วให้ MikroTik เป็นสั่งการเชื่อมต่อ PPPOE
- WAN2 เป็น Static ทำการ Fix IP อุปกรณ์เพื่อออกเน็ตตามที่ต้องการ (ตัวอย่าง IP: 61.7.236.35/28 , ชี้ Gateway ไปที่ 61.7.236.33)
ต้องทำอย่างไร?

คำตอบ


Port1 - WAN1 (PPPoE1)
Port2 - WAN2 (Static2)
Port3 - NONE (ไม่ใช้งาน)
Port4 - Loadbalance WAN1,WAN2 + Hotspot (รวมเน็ตทั้ง 2 เส้น เข้าด้วยกันแล้วออกมาเป็น Hotspot)
port5 - NONE (ไม่ใช้งาน)


    การเซต Loadbalance เข้า port1,2 ออก port4


    1. ดาวน์โหลด Winbox แล้วเสียบสาย LAN ขา Ether5 ของ MikroTik
      เข้าโปรแกรม Winbox แล้วคลิกเลือก mac address MikroTik ที่ broadcast เจอ แล้วกด Connect

      รูปภาพ



    2. จะมี mac address ของขา LAN Mikrotik ที่เราเชื่อมต่ออยู่ ขึ้นมา กด Connect เพื่อเชื่อมต่อ

      รูปภาพ


    3. Winbox กำลังเชื่อมต่อเข้าไปยัง Mikrotik

      รูปภาพ


    4. ปกติแล้ว MikroTik แทบทุกรุ่นจะมี config default ให้ แต่เราจะไม่ใช่ครับ กด Remove Configuration ได้เลย

      รูปภาพ


    5. RB750GL จะทำการ Remove config default ออก แล้วจะ reboot ตัวเอง ถ้าเกิด message เด้งขึ้นมา ก็ไม่ต้องตกใจน่ะครับ

      รูปภาพ


    6. สร้าง Connection PPPOE ผ่านเมนู PPP

      รูปภาพ


    7. ที่เมนู PPP กดปุ่ม + เพื่อสร้าง PPPOE โดยเลือก PPPOE Client

      รูปภาพ

    8. สร้าง pppoe-out1 (ตัวอย่างเป็นเน็ต 3BB)

      รูปภาพรูปภาพ

    9. สร้าง IP Route (Winbox > IP > Route กด + เพื่อสร้าง New Route)
      สร้างใหม่ 4 Route รูปตามด้านล่าง
      003 route1.png
      003 route1.png (17.57 KiB) เปิดดู 9601 ครั้ง

      004 route2.png
      004 route2.png (17.71 KiB) เปิดดู 9576 ครั้ง

      005 route3.png
      005 route3.png (18 KiB) เปิดดู 9566 ครั้ง

      006 route4.png
      006 route4.png (18.27 KiB) เปิดดู 9572 ครั้ง

    10. ทำการ code เพิ่มเติมนิหน่อย ผ่าน Terminal
      เข้าเมนู New Terminal > Terminal

      รูปภาพ

      Script : 2 WAN(1PPPoE + 1Static) to 1 LAN
      โค้ด: เลือกทั้งหมด
      /ip address add address=61.7.236.35/28 network=61.7.236.0 interface=ether2

      /ip firewall mangle
      add action=mark-routing chain=prerouting dst-address-type=!local new-routing-mark=wan_1 passthrough=no per-connection-classifier=both-addresses-and-ports:2/0
      add action=mark-routing chain=prerouting dst-address-type=!local new-routing-mark=wan_2 passthrough=no per-connection-classifier=both-addresses-and-ports:2/1

      /ip firewall nat
      add action=masquerade chain=srcnat dst-address-type=!local out-interface=pppoe-out1
      add action=masquerade chain=srcnat dst-address-type=!local out-interface=ether2

      /ip dns set allow-remote-requests=yes servers=8.8.8.8,8.8.4.4


    11. คลิกขวา ที่แถบ command บน terminal แล้ว Paste

      รูปภาพ




        การตั้งค่า LAN-HOTSPOT1 SETUP ( port4=Hotspot)


      1. เข้าเมนู IP > Hotspot

        รูปภาพ

      2. แท็ป Server ทำการคลิก Hotspot Setup
        แล้วเลือก HotSpot Interface: ether4

        รูปภาพ

        รูปภาพ

        รูปภาพ

        รูปภาพ

        รูปภาพ

        **ปกติแล้ว MikroTik จะดึงค่า DNS มาให้อัตโนมัติครับ (ตัวอย่างเป็น DNS ของ 3BB)
        รูปภาพ

        รูปภาพ

        รูปภาพ

        รูปภาพ
SYS2U.COM 24-Hour Online IT Store - ซิสทูยู ออนไลน์ - http://www.SYS2U.com
1. ซิสทูยู ทีวี - http://www.youtube.com/user/SYS2UTV
2. ซิสทูยู เฟสบุ๊ค - http://www.facebook.com/SYS2UOnline

รูปภาพ
รูปภาพ
ภาพประจำตัวสมาชิก
jadeson
 
โพสต์: 619
ลงทะเบียนเมื่อ: อังคาร 03 ก.พ. 2009 4:50 pm

ย้อนกลับไปยัง วิธีการติดตั้งและปรับแต่งอุปกรณ์ Mikrotik

ผู้ใช้งานขณะนี้

กำลังดูบอร์ดนี้: ไม่มีสมาชิกใหม่ และ บุคคลทั่วไป 4 ท่าน