2.1.1 ติดตั้ง MikroTik แบบ 2 PPPOE to 1 LAN (LoadBalance+HS)

วิธีการติดตั้ง และปรับแต่งอุปกรณ์ Mikrotik
ให้รองรับการทำงานที่หลากหลายความต้องการ
การติดตั้ง HotSpot Server, การติดตั้ว Load Balanced ฯลฯ

Re: 2.1.1 ติดตั้ง MikroTik แบบ 2 PPPOE to 1 LAN (LoadBalance+HS)

โพสต์โดย vanjai11 เมื่อ เสาร์ 12 ต.ค. 2013 3:19 am

แล้วถ้าผมทำloadbalan Rb450(คือเน็ตรวมเรียบร้อยแล้ว35MB) แล้วจ่ายเน็ตไปที่HUB-------> RB750 ซึ่ง 750จะเป็นตัวจ่ายhotspotความเร็วอินเทอร์เน็ตยังจะรวมหรือเปล่าครับ10+10+15=35MBประมาณนี้ครับ

ขอบคุณครับ
vanjai11
 
โพสต์: 49
ลงทะเบียนเมื่อ: พฤหัสฯ. 22 ม.ค. 2009 2:51 am

Re: 2.1.1 ติดตั้ง MikroTik แบบ 2 PPPOE to 1 LAN (LoadBalance+HS)

โพสต์โดย jadeson เมื่อ จันทร์ 14 ต.ค. 2013 7:57 am

vanjai11 เขียน:แล้วถ้าผมทำloadbalan Rb450(คือเน็ตรวมเรียบร้อยแล้ว35MB) แล้วจ่ายเน็ตไปที่HUB-------> RB750 ซึ่ง 750จะเป็นตัวจ่ายhotspotความเร็วอินเทอร์เน็ตยังจะรวมหรือเปล่าครับ10+10+15=35MBประมาณนี้ครับ

ขอบคุณครับ


ได้เลยครับ ตัวอย่าง เน็ต 35Mb เข้าที่ Port 1 ของ Mikrotik เวลาทำ Hotspot เน็ตที่ออกมาก็จะวิ่ง 35 Mb
แต่ถ้าให้แนะนำเพิ่มเติมน่ะครับ ให้ใช้ตัวที่ สเป็กสูงกว่าเป็น Hotspot จะดีกว่าครับ จะได้รองรับ user ที่เข้ามาได้มากกว่าและนิ่งกว่าครับ
SYS2U.COM 24-Hour Online IT Store - ซิสทูยู ออนไลน์ - http://www.SYS2U.com
1. ซิสทูยู ทีวี - http://www.youtube.com/user/SYS2UTV
2. ซิสทูยู เฟสบุ๊ค - http://www.facebook.com/SYS2UOnline

รูปภาพ
รูปภาพ
ภาพประจำตัวสมาชิก
jadeson
 
โพสต์: 619
ลงทะเบียนเมื่อ: อังคาร 03 ก.พ. 2009 4:50 pm

Re: 2.1.1 ติดตั้ง MikroTik แบบ 2 PPPOE to 1 LAN (LoadBalance+HS)

โพสต์โดย aponline เมื่อ พฤหัสฯ. 24 ต.ค. 2013 11:11 pm

ต้องการทำ LoadBalance รวมเน็ตจำนวน 2 เส้น ของ tot wi net 10/512 และ 7/512 โดยใช้ MikroTik รุ่น RB750GL ต้องการรวมอย่างเดียวครับ
IP 10/512 192.168.101.1 และ 7/512 192.168.9.1 ผมขอ Script : 2 WAN to 1 LAN หน่อยครับเลข IP ตามนี้ครับ :D
aponline
 
โพสต์: 1
ลงทะเบียนเมื่อ: เสาร์ 19 ต.ค. 2013 12:15 pm

Re: 2.1.1 ติดตั้ง MikroTik แบบ 2 PPPOE to 1 LAN (LoadBalance+HS)

โพสต์โดย jadeson เมื่อ ศุกร์ 25 ต.ค. 2013 8:04 am

aponline เขียน:ต้องการทำ LoadBalance รวมเน็ตจำนวน 2 เส้น ของ tot wi net 10/512 และ 7/512 โดยใช้ MikroTik รุ่น RB750GL ต้องการรวมอย่างเดียวครับ
IP 10/512 192.168.101.1 และ 7/512 192.168.9.1 ผมขอ Script : 2 WAN to 1 LAN หน่อยครับเลข IP ตามนี้ครับ :D


เห็นแจ้งเป็น IP เข้ามาทั้ง 2 WAN เป็นแบบ Static ทั้ง 2 WAN ใช่ป่าวครับ
(ตัว tot wi net จ่ายสัญญาณ internet ออกมาแล้ว ผ่าน LAN ต่อเข้า mikrotik)

ตัวอย่าง วิธีการคอนฟิก
2.0 ติดตั้ง LoadBalance RB750GL แบบ 4WAN (Static IP) to 1LAN

ตัวอย่างโค้ด 2 Static to 1 LAN (ผมตัดบรรทัดที่ไม่ได้ใช้ออกให้แล้ว เหลือ 2 static - แก้ไข IP เป็นของคุณได้เลย)
โค้ด: เลือกทั้งหมด
#|/ip address
/ip address add address=192.168.1.2/24 network=192.168.1.0 broadcast=192.168.1.255 interface=ether1
/ip address add address=192.168.2.2/24 network=192.168.2.0 broadcast=192.168.2.255 interface=ether2

/ip address add address=192.168.0.1/24 network=192.168.0.0 broadcast=192.168.0.255 interface=ether5 comment="default configuration"

#|/ip firewall mangle
/ip firewall mangle add chain=input in-interface=ether1 action=mark-connection new-connection-mark=ether1_conn
/ip firewall mangle add chain=input in-interface=ether2 action=mark-connection new-connection-mark=ether2_conn

/ip firewall mangle add chain=output connection-mark=ether1_conn action=mark-routing new-routing-mark=to_ether1
/ip firewall mangle add chain=output connection-mark=ether2_conn action=mark-routing new-routing-mark=to_ether2

/ip firewall mangle add chain=prerouting dst-address=192.168.1.0/24 action=accept in-interface=ether5
/ip firewall mangle add chain=prerouting dst-address=192.168.2.0/24 action=accept in-interface=ether5

/ip firewall mangle add chain=prerouting dst-address-type=!local in-interface=ether5 per-connection-classifier=both-addresses-and-ports:1/0 action=mark-connection new-connection-mark=ether1_conn passthrough=yes
/ip firewall mangle add chain=prerouting dst-address-type=!local in-interface=ether5 per-connection-classifier=both-addresses-and-ports:1/1 action=mark-connection new-connection-mark=ether2_conn passthrough=yes

/ip firewall mangle add chain=prerouting connection-mark=ether1_conn in-interface=ether5 action=mark-routing new-routing-mark=to_ether1
/ip firewall mangle add chain=prerouting connection-mark=ether2_conn in-interface=ether5 action=mark-routing new-routing-mark=to_ether2

#|/ip route
/ip route add dst-address=0.0.0.0/0 gateway=192.168.1.251 routing-mark=to_ether1 check-gateway=ping
/ip route add dst-address=0.0.0.0/0 gateway=192.168.2.251 routing-mark=to_ether2 check-gateway=ping

/ip route add dst-address=0.0.0.0/0 gateway=192.168.1.251 distance=1 check-gateway=ping
/ip route add dst-address=0.0.0.0/0 gateway=192.168.2.251 distance=2 check-gateway=ping

#|/ip firewall nat
/ip firewall nat add chain=srcnat out-interface=ether1 action=masquerade
/ip firewall nat add chain=srcnat out-interface=ether2 action=masquerade

#| DHCP server is on switch, with address pool 192.168.0.100-192.168.0.200
/ip pool add name=default-dhcp ranges=192.168.0.100-192.168.0.200
/ip dhcp-server add name=default address-pool=default-dhcp interface=ether5 disabled=no
/ip dhcp-server network add address=192.168.0.0/24 gateway=192.168.0.1 dns-server=192.168.0.1 comment="default configuration"

#| DNS
/ip dns set allow-remote-requests=yes
/ip dns static add name=router address=192.168.0.1

#| Now Configure DNS server so users can resolve hostnames,
#| Ex.cache-size=5000KiB
#| DNS Google = 8.8.8.8,8.8.4.4
#| DNS 3BB = 110.164.252.222,110.164.252.223
/ip dns set allow-remote-requests=yes cache-max-ttl=1w cache-size=5000K max-udp-packet-size=512 servers=8.8.8.8,8.8.4.4


ปล.เป็นสินค้าจากทางร้าน เมล์แจ้ง s/n เข้า info@sys2u.com ได้เลยน่ะครับ ทางร้านจะได้ติดต่อโทรไปซัพพอร์ต+ remote เซตค่าให้ได้ครับ
SYS2U.COM 24-Hour Online IT Store - ซิสทูยู ออนไลน์ - http://www.SYS2U.com
1. ซิสทูยู ทีวี - http://www.youtube.com/user/SYS2UTV
2. ซิสทูยู เฟสบุ๊ค - http://www.facebook.com/SYS2UOnline

รูปภาพ
รูปภาพ
ภาพประจำตัวสมาชิก
jadeson
 
โพสต์: 619
ลงทะเบียนเมื่อ: อังคาร 03 ก.พ. 2009 4:50 pm

Re: 2.1.1 ติดตั้ง MikroTik แบบ 2 PPPOE to 1 LAN (LoadBalance+HS)

โพสต์โดย vanjai11 เมื่อ พุธ 30 ต.ค. 2013 3:42 pm

jadeson เขียน:
vanjai11 เขียน:แล้วถ้าผมทำloadbalan Rb450(คือเน็ตรวมเรียบร้อยแล้ว35MB) แล้วจ่ายเน็ตไปที่HUB-------> RB750 ซึ่ง 750จะเป็นตัวจ่ายhotspotความเร็วอินเทอร์เน็ตยังจะรวมหรือเปล่าครับ10+10+15=35MBประมาณนี้ครับ

ขอบคุณครับ


ได้เลยครับ ตัวอย่าง เน็ต 35Mb เข้าที่ Port 1 ของ Mikrotik เวลาทำ Hotspot เน็ตที่ออกมาก็จะวิ่ง 35 Mb
แต่ถ้าให้แนะนำเพิ่มเติมน่ะครับ ให้ใช้ตัวที่ สเป็กสูงกว่าเป็น Hotspot จะดีกว่าครับ จะได้รองรับ user ที่เข้ามาได้มากกว่าและนิ่งกว่าครับ[/qu

ขอบคุณครับ
vanjai11
 
โพสต์: 49
ลงทะเบียนเมื่อ: พฤหัสฯ. 22 ม.ค. 2009 2:51 am

Re: 2.1.1 ติดตั้ง MikroTik แบบ 2 PPPOE to 1 LAN (LoadBalance+HS)

โพสต์โดย tanarat2012 เมื่อ พุธ 25 ธ.ค. 2013 8:46 pm

เซ็ท router เป็นบริจด์ ตัวที่1 (wan1) กับตัวที่ 2 (wan2) ต้องตั้ง ip ให้เราเตอร์อยู่ในวงไหนครับ
tanarat2012
 
โพสต์: 25
ลงทะเบียนเมื่อ: จันทร์ 17 ธ.ค. 2012 2:32 pm

Re: 2.1.1 ติดตั้ง MikroTik แบบ 2 PPPOE to 1 LAN (LoadBalance+HS)

โพสต์โดย jadeson เมื่อ พฤหัสฯ. 26 ธ.ค. 2013 8:12 am

tanarat2012 เขียน:เซ็ท router เป็นบริจด์ ตัวที่1 (wan1) กับตัวที่ 2 (wan2) ต้องตั้ง ip ให้เราเตอร์อยู่ในวงไหนครับ


ปกติแล้ว โมเด็มของ WAN1 และ WAN2 จะเป็น ip วงไหนก็ได้ครับ ขอแค่เป็นบริดจ์โหมดก็ใช้งานได้แล้ว แต่ถ้าจะให้ดี ทั้ง WAN1 และ WAN2 และ IP หลังวง LAN ควรเป็นคนละวงกันจะดีที่สุดครับ

เวลาโค้ดจะได้ไม่สับสน route ip ไม่ชนกัน
SYS2U.COM 24-Hour Online IT Store - ซิสทูยู ออนไลน์ - http://www.SYS2U.com
1. ซิสทูยู ทีวี - http://www.youtube.com/user/SYS2UTV
2. ซิสทูยู เฟสบุ๊ค - http://www.facebook.com/SYS2UOnline

รูปภาพ
รูปภาพ
ภาพประจำตัวสมาชิก
jadeson
 
โพสต์: 619
ลงทะเบียนเมื่อ: อังคาร 03 ก.พ. 2009 4:50 pm

Re: 2.1.1 ติดตั้ง MikroTik แบบ 2 PPPOE to 1 LAN (LoadBalance+HS)

โพสต์โดย tanarat2012 เมื่อ จันทร์ 30 ธ.ค. 2013 12:04 am

หลังจากผมตั้งค่าเสร็จที่ ข้อ15 (ก่อนเปิด hotspot) เน็ตปกติครับ ลื่นดีครับ แต่พอหลังจากเปิด hotspot แล้ว เน็ตไม่ดีเลยครับเข้าเว็บบ้างเว็บก็ไม่ได้ ถึงได้บ้างทีก็ช้ามากครับ เป็นเพราะอะไรครับแล้วต้องแก้ตรงไหนครับ รบกวนหน่อยนะครับ(หากใช้ default ของ user profile เน็ตก็ปกติครับ)
tanarat2012
 
โพสต์: 25
ลงทะเบียนเมื่อ: จันทร์ 17 ธ.ค. 2012 2:32 pm

Re: 2.1.1 ติดตั้ง MikroTik แบบ 2 PPPOE to 1 LAN (LoadBalance+HS)

โพสต์โดย jadeson เมื่อ พฤหัสฯ. 02 ม.ค. 2014 4:13 pm

tanarat2012 เขียน:หลังจากผมตั้งค่าเสร็จที่ ข้อ15 (ก่อนเปิด hotspot) เน็ตปกติครับ ลื่นดีครับ แต่พอหลังจากเปิด hotspot แล้ว เน็ตไม่ดีเลยครับเข้าเว็บบ้างเว็บก็ไม่ได้ ถึงได้บ้างทีก็ช้ามากครับ เป็นเพราะอะไรครับแล้วต้องแก้ตรงไหนครับ รบกวนหน่อยนะครับ(หากใช้ default ของ user profile เน็ตก็ปกติครับ)


หลังทำ Hotspot แล้ว ความเร็ว Internet ที่ได้จะไม่รวมแล้วน่ะครับ จะเป็นเหมือน Link backup คือวิ่งเส้นใด เส้นหนึ่งก่อน จนกว่าจะมีปัญหาแล้วถึงจะสลับไปอีกลิงค์ที่ใช้งานได้ถัดไปให้อัตโนมัติ

- ถ้าใช้ user profiles ปกติ สามารถ login เข้าใช้งานได้ปกติ ให้ลองเช็ค profiles ตัวที่มีปัญหาดูครับว่า ตั้งค่าอะไรไว้บ้าง มีการ limit อะไรไว้หรือป่าว
หรือจะลองสร้าง user profiles ใหม่ ไม่ต้องกำหนดค่าใดๆ ลองใช้งานดูก่อนก็ได้ครับ ถ้าได้ปกติแล้วค่อยทดสอบตั้งเวลา และตั้ง limit การใช้งานตามลำดับอีกที
SYS2U.COM 24-Hour Online IT Store - ซิสทูยู ออนไลน์ - http://www.SYS2U.com
1. ซิสทูยู ทีวี - http://www.youtube.com/user/SYS2UTV
2. ซิสทูยู เฟสบุ๊ค - http://www.facebook.com/SYS2UOnline

รูปภาพ
รูปภาพ
ภาพประจำตัวสมาชิก
jadeson
 
โพสต์: 619
ลงทะเบียนเมื่อ: อังคาร 03 ก.พ. 2009 4:50 pm

Re: 2.1.1 ติดตั้ง MikroTik แบบ 2 PPPOE to 1 LAN (LoadBalance+HS)

โพสต์โดย thawatchai30 เมื่อ พฤหัสฯ. 24 เม.ย. 2014 3:46 pm

สอบถามเพิ่มเติมหน่อยครับ ถ้าผมต้องการทำload balance 2 WAN PPPOE แค่ออกเน็ตเฉยๆต้องเซ็ตไงบ้างครับ ขอบคุณครับ
thawatchai30
 
โพสต์: 20
ลงทะเบียนเมื่อ: ศุกร์ 21 ต.ค. 2011 3:25 am

ย้อนกลับต่อไป

ย้อนกลับไปยัง วิธีการติดตั้งและปรับแต่งอุปกรณ์ Mikrotik

ผู้ใช้งานขณะนี้

กำลังดูบอร์ดนี้: ไม่มีสมาชิกใหม่ และ บุคคลทั่วไป 5 ท่าน